Microsoft Excel 2016 - Data Analysis Add-Ins

CHAPTER 1 POWER V|EW

< )lNFOCUS

Power View is a data exploration, visualisation and presentation tool that
provides you with the ability to create interactive tables, charts and maps
from your workbook data through an easy-to-use interface.

With Power View you can create dashboards that provide alternate and
complementary views of your workbook data, as well as drilling down into that
data with filtering and tile grouping. You can see the data in tables and charts
and switch effortlessly from one to the other.

Power View is an add-in (only available in the Office Professional Plus and
Office 365 Professional versions of Office 2016).

In this session you will:

gain an understanding of how Power View works
learn how to enable the Power View add-in

learn how to enable the Power View add-in

learn how to create a Power View sheet

learn how to work with visualisation objects in a Power
View sheet

learn how to manipulate the fields in a Power View report

learn how to rearrange and sort fields in a Power View
sheet

learn how to work with measure fields in Power View
learn how to format Power View data

learn how to tile data

learn how to filter data in Power View

learn how to switch data visualisations

learn how to add more views to a Power View sheet
learn how to add titles and a background image

learn how to refresh a Power View report.
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UNDERSTANDING POWER VIEW

Power View provides a visual and interactive
way of seeing data that is either currently in a
workbook or is external to it. A Power View

report is created in a new sheet. This sheet can

Microsoft Excel 2016 - Data Analysis Add-Ins

hold several visualisation objects that interpret

and analyse the data attached to them. These
objects can take the form of a table (a bit like a

PivotTable), a chart or a map.

The Data

Generally, the data used for a Power View report will come from some sort of list, either one that has
been created within the workbook or from an external data source such as a database application like
Microsoft Access. List data has historically been difficult to analyse without complex data manipulation

tools.
A E C D E G

1 [Horlest Ted's Used Car Sales
2 |1st Quarter Sales
3
4 |No Month Salesperson Make Model Type Colour
5 1 31-Jan Mary O'Dwyer Toyota Corolla Sedan Red
6 2 31-Jan Justin Callaghan BMW 3 Series Sedan Silver
7 3 31-Jan Hector Smith Toyota Celica Coupe Yellow
8 4 31-Jan Mary O'Dwyer Ford Explorer SUV Silver
9 5 31-Jan Mary O'Dwyer Hyundai Elantra Sedan White
10 6 31-Jan lJustin Callaghan Ford Fiesta Sedan Green
11 7 31-Jan Hector Smith BMW 23 Coupe Silver
12 8 31-Jan Hector Smith Toyota Corolla Sedan White
13 9 31-Jan Mary O'Dwyer Toyota Activa Wagon Yellow
14| 10 31-Jan Mary O'Dwyer KIA Mini Sedan Red
15 11 31-Jan Mary O'Dwyer Volkswagen Toureg SUV Silver

The Power View Report

Using data such as that above a Power View report can be created. The report below contains 2 objects
— one in tabular format and another in a chart visualisation. Basically, they show the total sales at Honest
Ted’s Used Cars over three months. There are filter settings at the right which allow even further drilling

down into the data.
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In this view only sales
for BMW and
Volkswagen vehicles
are shown — these are
the two vehicle makes
that have been ticked
in the filters pane.

Since there are no
ticks in any of the filter
boxes here we are
seeing an analysis of
all of the data from the
data source.
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ENABLING POWER VIEW

Power View is an add-in for Excel 2016 that is Add-ins are generally enabled from the Add-Ins
normally installed when Office and Excel are tab on the Excel Options dialog box. This dialog
installed. However, it still may need to be enabled box is accessed through the File tab on the ribbon.

before it will appear as a tab in the ribbon.

Excel Options ? ®
Try Th I S YO u rs el f . General D View and manage Microsoft Office Add-ins.
Formulas
S o Before starting this exercise Proofing Add-ins
§ T You MUST ensure that save Name Location Type .
EXCE| has Started e I;ﬂ:.guagel Acrobat PDFMaker Office COM Addin C:\...DFMaker\Office\PDFMOQfficeAddindll  COM Add-in
o Click on the File tab, then Customize fibbon Analysis ToolPak Co\..ffice16\Library\Analysis\ANALYS32.XLL  Excel Add-in
click on Options fo display | | @ | e S
i i Al Euro Currency Tools Ci\ooth Office] B\Libran\EUROTOOLXLAM  Excel Add-in
the Excel OpthﬂS dlalog it Center Inquire C:'.."ﬁttz'.mct".;fﬂ(aE,:.DCF".Natw.-eSh?:m.cIH COM Add-in
box - Micrasoft Actions Pane 3 ¥ML Expansion Pack
Microsoft Power Map for Excel Ci\... Excel Add-in\EXCELPLUGINSHELLDLL ~ COM Add-in
. . . Microsoft Power Pivot for Excel dd-im\PowerPivetExcelClientAddindll  COM Add-in
e Click on Add-ins to dlsplay M\crcscf:Pt:w&r'd'iewtforExcel tItI-\n':-"a(chcREr:crtingExcetIC\ienttl\l COM Add-in
a |ISt Of add-lnS Currently Solver Add-in G\, ficelB\Libran\SOLVER\SOLVER XLAM  Excel Add-in
installed in Excel
e Click on the Manage drop Adc-in: Actobat PDFMsker Offics COM Addin
Publisher:  Adobe Systems, Incorporated
arrow (at the bOttom Of the Compatibility: No ccm;(a::ibi\it;‘- mfcfmatitcn available
WindOW), select COM Add- ‘ Location: C:\Program Files (x25\Adobe\ Acrobat DC\PDFMaker\ Office\PDFMOfficeAddin.dll
ins, then click on [GO] to ‘ Description: ~ Acrobat PDFMaker Office COM Addin
display a list of COM Add-
ins available to you W Mansge: |Excel Add-ins v Go..
There are different types of 9 oK || Conce
add-ins for Excel. COM
Add-ins are ones that can e
be used by other Office
applications...
o Ensure the checkbox for COM Add-Ins rox
Microsoft Power View for Add-Ins available:
Excel appears t|Cked ZAcropat PDFMaker Office COM Addin
%Inqulre Cancel
. Microsoft Power Map for Excel
e C||Ck on [OK] ;|Microsoft Power Pi\r:tfor Excel add
. . . . | Microsoft Power View for Excel =
There’s no indication at this r—
stage that the changes
haVe been made Location: C\Program Files (x86)\Microsoft Office\Root\Office 16\ ADDINS\Power View Excel Add-in\AdHocRep
SUCCGSSfU”y- We COUId Load Behavior: Load at Startup
return to the Add-Ins
settings but for the purpose
of this exercise we will o
assume the changes were
successful
For Your Reference... Handy to Know...
To enable the Power View add-in: e The Power View add-in is only available to
1. Click on the File tab, click on Options, then you if you are using Office Professional
click on Add-ins Plus or Office 365 Professional Plus.

2. Click in the checkbox left of Microsoft
Power View for Excel to enable it

3. Click on [OK]
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Power View is an add-in for Excel 2016 that is
normally installed when Office and Excel are
installed. However, it still may need to be added
to the ribbon as it does not appear by default.

Microsoft Excel 2016 - Data Analysis Add-Ins

ADDING POWER VIEW TO THE RIBBON

You can add commands to the ribbon from the

Customise Ribbon tab in the Excel Options
dialog box. This dialog box is accessed through the

File tab.

Customize the Ribbon: (G

Customize the Ribbon:

Try Thls Yourself. Main Tabs w Main Tabs w
. . g Main Tabs - Main Tabs ~
c o Before starting this exercise you [ Home [l Home
o T MUST ensure that Excel has = A Insert = Hlnsert
@] started. .. Tables Tables
lllustrations Illustrations
i X i Add-ins Add-ins
Click on the File tab, then click on Charts Charts
R R Tours Tours
Opt!ons tO dISp|ay the Excel Sparklines Sparklines
Options dialog box Filters Filters
Links Links
Click on Customise Ribbon to ;extb | gextb |
g g q-f H Sy s H Gy 5
display options for customising the o i,
ribbon MNew Group (Custorn) Bl Reports (Custom)

In the right pane, click on Insert to
select it, then click on [New Group]

apply this name to the new group

Click on the drop arrow under
Choose commands from, then
select Commands Not in the
Ribbon to display commands in the
left pane that are not already on the
ribbon

In the left pane, scroll down and click
on Insert a Power View Report,
then click on [Add] to add it to the
new group on the Insert tab

Click on [OK] to return to the
workbook, then click on the Insert tab

o0 6 o6 0 ©

© ©

The Power View command appears
in the new Reports group at the right
end of the ribbon

Page Layout
Formulas
Data

M Formulas
(A Data

2] Insert a Power View Repor
Page Layout

Review

We will add the command to a new & View [ Review
group on the Insert tab... [ Developer View

[ Add-ins [1Developer y
In the right pane, right-click on New ] ACROBAT v e >
Group (Custom) and select Rename | || newTeb | | NewGroup | | Rename.. NewTab | | NewGroup | | Rename..
to dlsplay the Rename d|a|0g bOX Customizations: r Reset ~ i Customizations: Reset «
Type Reports, then click on [OK] to Import/Export + | Import/Export ~ |G

HD 4 2 T Q M

Text Header WordArt Signature Object Equation Symbol =~ Power

Box & Footer - Line~
Text

-

Symbols

View
Reports

2_ Share

For Your Reference...
To add Power View to the ribbon:

Handy to Know...

e The Power View add-in is only available to

you if you are using Office Professional

1. Click on the File tab, click on Options, then
Plus or Office 365 Professional Plus.

click on Customise Ribbon

2. Click on the required tab and group in the
right pane

3. Click on Insert a Power View Report in the
left pane, click on [Add], then click on [OK]
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CREATING A POWER VIEW SHEET

A Power View report is created on a special
Power View sheet — it's a bit like having a chart
on a chart sheet. When you insert a Power View
report using the Insert tab, a new sheet will be

created with a new Power View visualisation object
on it. A Power View Fields pane will appear with
the fields (columns) shown from the data listing you
have selected for the view.

Try This Yourself:

Before starting this

exercise you MUST
open the file Power
View_1.xlsx...

Open
File

Click in cell A4

This is the first cell in
the list of data. You can
actually click anywhere
in the list to create a
Power View report...

Click on the Insert tab,
then click on Power
View in the Reports

group

After a few moments a
new Power View sheet
will appear with its
initial interpretation of a
visualisation based on
the data from the
selected list.

If a message is
displayed notifying you
that Power View
requires a current
version of Silverlight,
follow the prompts to
install or update
Silverlight, then click
Reload to try again

a A B z D E

1 |Honest Ted's Used Car Sales

2 |1st Quarter Sales

3 '

4 m Month Salesperson Make Model

5 | 1 31-Jan Mary O'Dwyer Toyota Corolla

6 2 31-Jan Justin Callaghan BMW 3 Series
7 3 31-Jan Hector Smith Toyota Celica

8 4 31-Jan Mary O'Dwyer Ford Explorer

H = PowerView_Txlsx - Excel
File Home Insert Page Layout Formulas Data Review View Power View DESIGN
, | amac General A
e =
El E \HE L =l & -l 1
Table Bar Column Other Map | Tiles Tile | Slicer | Card Show Totals Bring  Send
Chart~ Chart~ Chart~ Type Style~ Levels v Forward ~ Backward ~
Switch Visualization Tiles Slicer Options Number Text Anange S
Power View Fields x
ACTIVE AL
4F Range
[ age
[]  Age Grouping
] colour
Make
Model
Month
[¥]% No
Drag fields between areas below:
TILEBY
FIELDS
= No -
Month -~
Salesperson -
Make -
Madel -
Tpe -~
| Data sheet | Power View2 ® [l »
Ready £ EH |- 1} +  100%

The table that appears in the Power View sheet above is known as a
visualisation object. Selection handles (that allow you to resize the object)
appear around it when it is selected. Also, when it is selected additional
commands appear on a DESIGN tab. At the right you'll see the Power
View Fields pane — the fields that are ticked are the ones currently in use
in the select visualisation object at the left.

For Your Reference...

To create a new Power View sheet: .

1. Click in any cell of a list

2. Click on the Insert tab, then click on Power

View in the Reports group

Handy to Know...

To connect to an external source, you can
use the Power Pivot add-in to create a Data
Model within the workbook. When you create
a Power View report in a workbook that has
a Data Model the report will automatically
connect up with the Data Model.

© Watsonia Publishing
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WORKING WITH A POWER VIEW OBJECT

Power View reports are made up of Power View sheet, which can enable you to make
visualisations that appear in the Power View complex dashboards. When a visualisation object
sheet. These visualisations are objects and you is selected, handles will appear around it and
can have multiple visualisation objects on a appropriate commands will appear on the ribbon.
Try This Yourself: -
7 31/01/2016 Hector Smith BMW 3 Chype
Continue using the s i
£ © previous file with this A
$ & exercise, or open the file ot oo e o
Power View_2.xlIsx... D o conghan swr 3 s oot
25 31/01/2016 Justin Callaghan BMW 7Series  Sedan
. . 16 31,/01/2016 Justin Callaghan BMW 2 Coupe
0 Click to the right of the SRR
table in the Power View i eranis o teme
report to deselect it e e
The selection handles
around the table object
will disappear and the
DESIGN tab will no longer
be available... e
e Click anywhere on the
table to select it again
e Point to the table, then :
click on Pop out as s oL
shown to expand the table | | * 70 o 0 0 &
into the available space B riovects HeoSs Gt v Y
18 21,/01/2016 Hector Smith Hyundai  Elantra Coupe
o Point to the table, then A ot —
click on Pop in to o o M e i Tttt 0t -
. . 2 31/01/2016 Justin Callaghan BMW 3Series  Sedan (2]
shnnk the table aga|n 25 21/01/2016 Justin Callaghan BMW 7Series  Sedan
16 31/01/2016 Justin Callaghan BMW 7Y Coupe
. & 31,/01/2016 Justin Callaghan Ford Fiesta Sedan
e Point to the table, then R e
click on Show Filters |7/ L St i Ssew 2
to see how the data is
filtered
e Click on VIEW directly
under Filters to show
filters for the view rather
than for the table e
There are no filters
currently applied to the
view

For Your Reference... Handy to Know...
To work with a Power View object: e You can resize a visualisation object by
1. Select the Power View object dragging its handles. This will enable you to

see more of the records (rows) or the fields

2. Point to a selected object to see the Pop out
(columns).

tool and the Show Filters tool
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The selection of Power View fields at the right of
the sheet determine what will appear in the

visualisation object at the left. Unlike

Microsoft Excel 2016 - Data Analysis Add-Ins

WORKING WITH POWER VIEW FIELDS

rows and columns structure. The fields are more

like a stack, and each item placed into the stack
will appear in the object in the order in which it is

PivotTables however, the fields do not form a stacked.
. Power View Fields x Power View Fields
Try Thls Yourself ACTIVE ALL ACTIVE ALL
. . . . 4 Range - A e
2 Continue using the previous file QDREQAQE DRa;Age
@ T Wwith this exercise, or open the file [] Age Grouping [] Age Grouping
& Power View_3.xIsx... [l colour [l colour
[]  Make []  Make
If necessary, click in the table to 0 o B o
. . . . [ Month Month -
select it and display the fields in e e
the Power View Fields pane (] Payment Method []  Payment Methad
g g I:‘Z Price I:‘Z Price
Click in the checkbox for each of [] Region ] Region

© © ©6 6 6 00 O

the ticked fields to remove the
ticks in order to remove all of the
fields from the Power View object

If necessary, click on the white
arrow at the left of Range in the
fields pane to expand the field list
again

Click on the checkbox for Month
to display each month (end)
included in the table

Click on the checkbox for
Salesperson to display each
salesperson for each month

Click on the checkbox for Price to
see a sum of sales for each
salesperson for each month

Remove the ticks then try each of
the following:

Salesperson, Month, Price

Dirag fields between areas below:

FIELDS

Drrag fields between areas below:

TILE BY

FIELDS
Month -

FIELDS
Month
Salesperson -
X Price

Salezperson Price

109335
44020
167031
61358
21020
120840

Month
31/01/2016 Hector Smith
31/01,/2016 Justin Callaghan
31/01,/2016 Mary O Dhanyer
28/02/2016 Hector Smith
25/02/2016 Justin Callaghan
28/02/2016 Mary O Dwnyer

Make, Price e The order of the stack 31/03/2018 Hecter Smith - 120080
Price Make ShOWn in FlELDS above 31/03,/2016 Justin Callaghan 125810
Type, Price determines the column 31/03/2018 Mary O'Dwyer 182753

Payment Method, Price
Age Grouping, Price

order of the table

Total 992207

For Your Reference...
To use fields in the Power View report:

1. Click on the checkbox next to the desired

Handy to Know...

e The order in which the fields are used

determines the sorting order in the table.

field in the field pane so it is ticked, or .

2. Drag the field from the list to the desired
position in the stack

You can also drag the fields from the field list
into the stack. This is handy when you want
to insert a field in the middle of the stack.
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REARRANGING AND SORTING FIELDS

You can add or remove fields from the Power pane. Normally, the order in which fields appear in
View sheet by ticking or unticking the field in the the stack determines the sort order in the view, but
field pane. You can also drag the fields on or off you can override this by clicking on the field

the field stack shown in the FIELDS area on the headings in the table view.

. . e Salesperson Month Price Age Grouping
Try ThIS Yourself' Hector Smith  31/01/2016 6700 25 or less
Hector Smith  31/01/2016 40600 26-35
© ° Continue using the previous Hector Smith  31/01/2016 23500 26-45
9 . . . Hector Smith  31/01/2016 38535 46-55
&)5 [ file V\_”th this exeruse, or open Hector Smith  22/02/2016 27010 25 or less
the file Power V|6W_4-X|SX--- Hector Smith  28/02/2016 3200 26-35 FIELDS
Hector Smith  23/02/2016 13230 36-45 Salesperson -
o Select the table, remove all of HectorSmith  28/02/2016 15400 46-55 Month -
the t|CkS |n POWGI’ V|eW HectarSmfth 28/02/2016 2500 Ower E5 ¥ Price -
. R . Hecter Smith 31/03/2016 14098 2% or less Age G . -
Fields, then tick the following HectorSmith  31/03/2016 52400 26-35 gese
(in this Order): Salesperson, Hector Smith  31/03/2016 12000 36-45
i Hector Smith  31/03/2016 46250 46-55
Month, Price Hector Smith  31/03/2016 34222 Over55
H H H Justin Callaghan 31/01/2016 11220 25 or less
@ Placeatickin Age Grouping e R G-
to add this field to the
selections
e Salesperson Age Grouping  Month Price
e Click on Age Grouping in the Hector Smith 25 or lass 31/01/2016 6700
. Hector Smith 25 or less 28/02/2016 27019
FIE)LIDS ssta(l:k’ then drag It up Hector Smith 25 or less 31/03/2016 140935
to below Salesperson HectorSmith  26-35 31/01/2016 40600
. . Hector Smith  26-35 28/02/2016 3200
o Click on Month, then drag it HectorSmith  26-35 31/03/2016 5249 FIELDS
up to be'ow Sa'esperson Hector Smith  36-45 31/01/2016 23504 Salesperson -
Hector Smith  36-45 28/02/2018 1323 Age Grouping -
e Point to the Age Grouping Hecwor Smith  36-45 31/03/2016 1290 Month =
field heading in the table, HectarSm?th 45-5f 31/01/2016 3855 | 5 pic -
. . Hecter Smith 46-55 23/02/2016 15404
then click once to sort it HectorSmith  46-55 21/03/2016 4623
R R 4 Hecter Smith Cwer 55 28/02/2016 2500
G Click the heading again to Hector Smith  Over 58 31/03/2016 34223
sort in descending order Justin Callaghan 25 o less 31/01/2016 11220
o Click on the Month heading
to SOF'[ by month o Salezperson Month Age Grouging * Price
e C“Ck on the Sa|eSpel‘SOI’] Hector Smith 28/02/2016 Cner 55 I%ge Grouping
. Hector Smith  31/03/2016 Over 55 34722
headlng to Sort by Justin Callaghan 31/01/2016 Ower 55 12400
salesperson Justin Callaghan 31/02/2016 Over 55 15400
Mary O'Dwyer  31/01/2016 Ower 55 12300
Mary O'Dwyer  23/02/2016 Ower 55 2400
Mary O"Dwyer  31/03/2016 Over 55 54000
Hector Smith  21/01/2016 46-55 38855
Hector Smith  28/02/2016 46-55 15400
Hector Smith  21/03/2016 46-55 46250
Justin Callaghan 31/01/2016 46-55 15200
Justin Callaghan 31/03/2016 46-55 5900
Mary O'Dwyer  31/01/2016 46-55 26411
Mary O'Dwyer  23/02/2016 46-55 97700
Mary O'Dwyer  21/03/2016 46-55 87700
For Your Reference... Handy to Know...
To rearrange and sort fields: e A small triangle appears next to a field name
e Tick the checkbox next to the fields in the in the visualisation table to indicate the
Power View Fields pane to add them to the direction of the sort. An up triangle indicates
table an ascending sort, while a down triangle
e Click and drag the fields on or off the indicates a descending sort.

FIELDS stack
e Click on the heading in the table to sort it

© Watsonia Publishing Page 8 Chapter 1 - Power View
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WORKING WITH MEASURE FIELDS

Fields in Power View are either measure or non-
measure fields. Numeric fields are usually, but
not always, measure fields. A measure field is a
special type of field used to aggregate with

operations such as SUM, COUNT, or AVERAGE.
In Power View, fields that are measure fields have
a special character (e.g. sigma  is used for SUM
operations) to the left of the field name.

Try This Yourself:

Same
File

Continue using the
previous file with this
exercise, or open the file
Power View_5.xlIsx...

Remove all of the ticks in
the Power View Fields
pane, then tick the
following: Month,
Payment Method, Price,
No

The No field really just
identifies the transaction
number and has nothing
to do with values as such.
Yet it has been summed
because it is a measure
field...

Click on the drop arrow to
the right of the No field in
the FIELDS pane

Select Count (Not Blank)
to count the transactions
rather than sum them

Click on the drop arrow
next to Price and select
Average to see the
average prices rather than
the sum

Manth Payment Method
31/01/2016 Bank Cheque
31/01/2016 Cash
31/01/2016 Credit Card
31/01/2016 Perzonal Cheque
280272016 Bank Cheque
28/02/2016 Cash
28/02/2016 Credit Card
28/02/2016 Personal Cheque
31/03/2016 Bank Chequs
31/03/2016 Cash
31/03/2016 Credit Card
31/03/2016 Personal Cheque
Total

FIELDS
Price Mo Month -
125436 130 Payment Method hd
13850 53 ¥ Price =
153100 101 N
o
23000 21 ) ‘%
o7000 454 Remove Field
14120 263 Do Mot Summarize
81018 403 v sum
10240 118
Average
167073 1417
10100 341 Minimum
190540 1107 Blaxinum
91810 735 Count (Mot Blank)
992207 5253 Count (Distinct)

Month Payment Method  Price Count of Mo
31/01/2016 Bank Chegque 125456 10
31/01/2016 Cash 13850 5
31/01/2016 Credit Card 153100 3
31/01/2016 Perzonal Chegue 23000 FIELD'S
28/02/2016 Bank Cheque 97000 Manth -
2B/02/2016 Cash 14120
28/02/2016 Credit Card 21018 Payment Method v
25/02/2016 Personal Cheque 10240 . Price v
31/03/2016 Bank Cheque 167073 # Count of No e
31/03/2016 Cash 10100
31/03/2016 Credit Card 1959540 14
31/03/2016 Perzonal Chegque 91810 9
Total 992207 102
° Month Payment Method  Awerage of Price Count of Mo
31/01/2016 Bank Chequs 12545.6 10
31/01/2016 Cash 2770
31/01,/2016 Credit Card 101375 E:f
31/01/2016 Perzonal Cheque 14000 2
28/02/2016 Bank Cheque B8318.18131318182 11
28/02,/2016 Cash 2353.333333333232 1
28/02/2016 Credit Card §326.5 12
28/02/2016 Personal Cheque 341333333333333 3
31/03/2016 Bank Cheque 9281.33333333333 15
31/03/2016 Cash 2525 4
31/02/2016 Credit Card 14252 8571428571 14
31/03/2016 Perzonal Chegue 1020111111111 a
Total 9727.51960784314 102

For Your Reference...
To work with measure fields:
1. Click on the drop arrow next to the field

name in the FIELDS stack

2. Choose the appropriate setting for the field

Handy to Know...

e You can make a field a non-measure field by
using the Do Not Summarise option in the
drop list.

e The Count (Distinct) setting will count only
the first instance of duplicate data in a field.
For example if there are 5 people called
Smith, only 1 will be returned in the count.

© Watsonia Publishing
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FORMATTING POWER VIEW DATA

Power View fields appear unformatted even when a visualisation object is selected. These
though their data source originals may have formatting commands allow you to change the
formatting applied to them. Basic formatting formatting of numbers and the overall appearance
commands are available on the DESIGN tab of the text — but they are limited.

Try This Yourself:

Same
File

Continue using the
previous file with this
exercise, or open the file
Power View_6.xlIsx...

Click on the first value in
the Average of Price
column in the table

Click on the DESIGN tab
and click on Comma Style
in the Number group to
format the numbers

Click on the drop arrow
that has appeared next to
Accounting in the
Number group and select
Currency to display a
currency sign next to the
numbers

Click on the first value in
Month, click on the drop
arrow that has appeared
next to Short Date in the
Number group and select
Long Date

Click once on Increase
Font Size in the Text
group to increase the
overall font size

Month Payment Method  Average of Price Count of No
31/01/2016 Bank Cheque 12,545.60 10
31/01/2016 Cash 277000 5
31/01/2016 Credit Card 19,137.50 g
31/01/2016 Personal Cheque 14,000.00 2
28/02/2016 Bank Cheque 381818 i1
28/02/2016 Cash 235333 6
28/02/2016 Credit Card 6.826.50 12
28/02/2016 Personal Cheque 341333 3
31/03/2016 Bank Cheque 0za183 18
31/03/2016 Cash 252500 4
31/03/2016 Credit Card 14,252.86 14
31/02/2016 Personal Cheque 10.201.11 a
Total 9.727.52 102
Month Payment Method  Awverage of Price Count of No
31/01/2016 Bank Chegus $12,545.60 10
31/01/2016 Cash $2,770.00 )
31/01/2016 Credit Card £10,137.50 8
31/01,/2016 Personal Chegque $14,000.00 2
28/02/2016 Bank Cheque 3881818 11
28/02/2016 Cash 3235333 ]
28/02/2016 Credit Card $6,826.50 12
28/02/2016 Personal Cheque 3341333 3
31/02/2016 Bank Cheque $90.221.832 12
31/02/2016 Cash $2,525.00 4
31/03/2016 Credit Card £14,252.86 14
31/02/2016 Personal Cheque £10,201.11 g
Total §9,727.52 102
Month Payment Method  Average of Price Count of No
Sunday,... Bank Chequs £12,E45 60 10
Sunday.... Cash $2,770.00 5
Sunday.,... Credit Card £19,137.50 g
Sunday.... Personal Chegue $14,000.00 z
Sunday.... Bank Cheque 3551818 11
Sunday,... Cash 4235333 &
Sunday,... Credit Card $6.526.50 12
Sunday.,... Personal Chegue 3341333 3
Thursday.... Bank Chequs 3023183 18
Thursday.... Cash $2,525.00 4
Thursday,... Credit Card $14,252.86 14
Thursday.... Personal Chegue £10.201.11 o
Total §9,727.52 102

For Your Reference...
To format Power View table data:
1. Click on a value in the field to be formatted actually part of Excel and has been

2. Choose the appropriate formatting option

from the DESIGN tab

Handy to Know...
e Power View is an add-in to Excel — it is not

developed in isolation to Excel. Don’t expect
the same level of rich formatting features in
Power View as you have in Excel.

© Watsonia Publishing

Page 10 Chapter 1 - Power View



Microsoft Excel 2016 - Data Analysis Add-Ins

TILING DATA IN POWER VIEW

Tiling in Power View is a useful way of viewing scrolling list. As you select each record, other data
data that has been categorised, by grouping data relating to that record is grouped and presented on
on a particular field. When a field has been tiled screen for you.

each of its unique data records appears in a

c e Hector
Try This Yourself: <
o Continue using the previous TILE BY
e o file with this exercise, or avw 31012018 11000 Salesperson ~
S open the file Power MW 28/02/2016 29478 FIELDS
View_7.xlsx... BMW  31/03/2016 33940 Make -
Ford 31/01,/2016 22100 Month -
o Remove all of the ticks in Ford  28/02/2016 2540 3 Price -
Power View Fields, then Ford  31/03/2016 5000
tick the following: o :g;ﬁg:: o
Sglesperson, Make’ Month' Hyundai 31/01/2016 18000
Price Kia  31/01/2016 500
q q KA 28/02/2016 2000
e Click on Salesperson in BN S
FIELDS and drag it up to the - -
TILE BY box e
Ma
The names of the 3 O'ng
salespeople will now appear
as tiles at the top of the .
ke Month Price
report... BMW 31/03/2016 13400
e Click on each of the names Ford\@p 31/01/2010 53211
in turn to see the sales that o EBBREDTS 10140
Ford 31/03/2016 12000
eaCh have made GMH 28/02/2016 13200
You may want to drag the e e
edge of the object down to KA 28/02/2016 4200
see the totals better... Mitsubishi 31/03/2016 25000 |  Make Menth Price
q Miszan 28/02/2016 14500 BMW 31/0z/2016 13400
o Click on the DESIGN tab, Nissan  31/03/2016 69720 | Ford  31/01/2016 S&21t
click on Tile Type in the Primer 244 R4E 47080 | Ford 28/02/2016 10140
Tiles group and click on Tile Ford  31/03/2016 12000
FlOW tO see the '[ileS GMH 28/02/2016 13200
Hyundai  31/01/2016 15600
S]rrangedtat the bottom of s 1/01/2016 12300
€ repor Kl 28/02/2016 4200
e Click on the drop arrow to s T =T
the right of Salesperson in
TILE BY and click on Hector ,J”’“: Mary
X i Callagha o
Remove Field L 0 Dwyer
For Your Reference... Handy to Know...
To tile data in Power View: e You can only tile one field in a visualisation
1. Drag the desired tiling field into the TILE BY object at a time. However, there is nothing
area in the Power View Fields pane stopping you creating another visualisation

2. Click on the various tiles to see the data for ClefEEs Ele I R 0.

that tile record
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FILTERING IN POWER VIEW

The Power View sheet provides access to a very unigue example of data that can be filtered is
useful filtering pane. This pane allows you to displayed with a tick box. Ticking a box applies a
select specific data to show. The process is filter on that data. The default shows no ticks
relatively simple and straightforward as each meaning that all data will be seen.

Filters ¢« x " Filters ¢ X
Try This Yourself: . -
B Make 4 Make 3
Continue using the @ A
() . . T . b Month P
£ @ previous file with this . .
% L exercise, or open the file R _—
Power View_8.xlIsx... A Ford
b Salesperson GMH )
o Remove all of the ticks in “ i
the Power View Fields, N
then tick the following: peuger
Salesperson, Make, e Reraut
Month, Price —
e Drag Salesperson from b Mot
FIELDS up to TILE BY R
g . (AL
e Point to the table, then click —— ) R
on the Show Filters icon to = G40
see the Filters pane TABLE
4 Make H ¢
0 Click on the arrow to the left - 7
of Make to see a list of filter . .
options . Hector
Ford m
e Click in the tick box for o
BMW, then Volkswagen to p Make  Momh  Pric
work with only these makes Witsubisi BMW  3101/2016 11000
Mizzan BMW 28/02/2016 20410
e Click on the tile for Justin L] g B voae e
Callaghan, then Mary - onsam supe B
O’'Dwyer to see their sales [] vetisuagen
of these vehicles e
You'll notice that the view
of the filter settings has
disappeared... o
@ Ciick in the data, then click
on TABLE in the Filters
pane Make Month Price
e Click on the arrow to the left Ceessgen s1/ouane 42700
of Make, then click in the Wolkswagen 22/02/2016 17900
box next to All until it is ::1':“‘-‘ Hvesne Ij::;";
empty to clear all filters
For Your Reference... Handy to Know...
To filter the data in Power View: e You can also see the Filters pane by clicking
1. Point to the table, then click on the Show on the Filters Area command in the View
Filters icon group on the Power View tab on the ribbon.

2. Click on the arrow to the left of the field to
filter

3. Tick the options to filter with
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